This framework is tested to work under Python 3.6.

The required dependencies are NumPy >= 1.10, joblib >= 0.9. You also need keras or you can write your own learning algorithms using your favorite deep learning framework.

For running some of the examples, Matplotlib >= 1.1.1 is required. You also sometimes need to install specific dependencies (e.g. for the atari games, you need to install ALE >= 0.4).

We recommend to use the bleeding-edge version and to install it by following the Developer install instructions. If you want a simpler installation procedure and do not intend to modify yourself the learning algorithms etc., you can look at the User install instructions.

Developer install instructions

As a developer, you can set you up with the bleeding-edge version of DeeR with:

git clone -b master

Assuming you already have a python environment with pip, you can automatically install all the dependencies (except specific dependencies that you may need for some examples) with:

pip install -r requirements.txt

And you can install the framework as a package using the mode develop so that you can make modifications and test without having to re-install the package.

python develop

User install instructions

You can install the framework with pip:

pip install deer

For the bleeding edge version (recommended), you can simply use

pip install git+git://